Degraded Performance

Incident Report for Tobi Cloud

Resolved

All systems remain stable. This incident is resolved.
Posted Apr 27, 2026 - 15:41 CDT

Update

We have deployed one more fix to resolve the issue. Please make sure to refresh your browser for it to take effect. We will continue to monitor to ensure everything remains stable.
Posted Apr 27, 2026 - 14:18 CDT

Monitoring

We have implemented the fix and seeing systems recover. We are continuing to monitor.
Posted Apr 27, 2026 - 12:22 CDT

Identified

We have identified an issue that is affecting performance and are working on putting a temporary fix in place to provide relief. Further updates again before 1:15pm ET.
Posted Apr 27, 2026 - 11:54 CDT

Update

We are continuing to investigate slowness with our databases. We will update again by 1:15pm ET.
Posted Apr 27, 2026 - 11:19 CDT

Investigating

Tobi is currently experiencing degraded performance as of 10:19 AM EDT, and the team is currently investigating the cause.
Posted Apr 27, 2026 - 09:54 CDT
This incident affected: Dispatch Operations (APIs - Driver Dispatch and Trip Status, APIs - Service Area Lookup, APIs - Direction, Distance and Geocoding, Job - Invoice Generation, Standing Orders, Recurring Route Creation, Job - Dispatch Engine for Autonomous Dispatch, Job - Process CSV for Trips, Process Claims & Attestations, Job - Daily Shift Creation, Config to Cache Sync up) and Driver App | Live GPS (Job - ETA Calculation).